[User] Error occured while looking up jndi resource with jndi name. (OpenESB-SE-3.0.5)

Robelis robelisb at yahoo.fr
Fri Dec 22 18:30:28 GMT 2017


Hello friends!
I currently have the same problem marcelo.moscoso had with the "Error
occured while looking up jndi resource with jndi name" error, and for which
he proposed a solution. I configured the context.xml file as it was
proposed. My problem is that I have only one MySQL database, I do not have
the SQL Server database. However, marcelo.moscoso said he solved the problem
with MySQL and SQL Server.
- Does this mean that I can not solve the problem by configuring the
context.xml file with the only MySQL database?
- Help me please.

This is my context.xml file
<?xml version="1.0" encoding="UTF-8"?>

<context xmlns="http://www.open-esb.net/standalone/jndi/">

        <dataSource-pool-properties>
            <dbConnector-name>MYSQLConnector</dbConnector-name>
           
<datasource-classname>com.mysql.jdbc.jdbc2.optional.MysqlDataSource</datasource-classname>        
            <resource-type>Datasource</resource-type>
            <database-name>MYSQL</database-name>       
            <database-vendor>Oracle</database-vendor>
            <database-version>5.6</database-version>                
            <dbconnector-description>DBConnector for
MySQL</dbconnector-description>
            <dataSource-properties>
                <property>
                    <name>user</name>
                    <value>root</value>
                    <description></description>
                </property>
                <property>
                    <name>password</name>
                    <value>""</value>
                    <description></description>
                </property>
                <property>
                    <name>hostName</name>
                    <value>localhost</value>
                    <description></description>
                </property>
                <property>
                    <name>port</name>
                    <value>3306</value>
                    <description></description>
                </property>
                <property>
                    <name>databaseName</name>
                    <value>bici_db</value>
                    <description></description>
                </property>    
            </dataSource-properties>
            <pool-properties>
                <property>
                    <name>initialSize</name>
                    <value>11</value>
                    <description></description>
                </property>
                <property>
                    <name>maxActive</name>
                    <value>20</value>
                    <description></description>
                </property>
                <property>
                    <name>maxIdle</name>
                    <value>11</value>
                    <description></description>
                </property>
                <property>
                    <name>minIdle</name>
                    <value>10</value>
                    <description></description>
                </property>
            </pool-properties>
        </dataSource-pool-properties>

        <jdbc-resources>
            <dbConnector-name>MYSQLConnector</dbConnector-name>
            <jndi-name>>MySQLServer01</jndi-name>        
            <description>Datasource connection to MySQL</description>
        </jdbc-resources>
</context>
Then I made the following configurations:
1- copy the MySQL JDBC driver: in C: \ OpenESB-SE-3.0.5 \ OE-Instance \ lib
\ ext
2.- set CA config-extension: DB_01
3. sun-database-binding application contigation: DB_01 and jndi_name
4.-bepl wsdl: jndi

After all that, I always have the same error at runtime.
I do not understand anything anymore.
Please help me. It's urgent.
Thank you in advance.




--
Sent from: http://openesb-community-forum.794670.n2.nabble.com/



More information about the User mailing list