[User] Web services in glassfish worked internally (via Netbeans) but not when called externally

Paul Perez paul.perez at pymma.com
Thu Sep 27 08:07:14 BST 2018


Hello
Nice to see new people working on OpenESB and be sure we will do our best to
help you. 
First question: Why do you use The Glassfish Edition of OpenESB since this
edition is deprecated and is not supported anymore ? 
Glassfish Edition stopped more than 3 years ago.
I really recommend you to use the Standalone edition
Thank you for your response

Best regards

Paul Perez Chief Architect
Pymma Consulting
--------------------------
Tel: +44 79 44 36 04 65 
Skype ID : polperez

-----Original Message-----
From: User <user-bounces at lists.open-esb.net> On Behalf Of SusoDominguez via
User
Sent: 24 September 2018 11:37
To: user at lists.open-esb.net
Cc: SusoDominguez <k1214757 at kcl.ac.uk>
Subject: [User] Web services in glassfish worked internally (via Netbeans)
but not when called externally

Hi all,
I am fairly new to openesb and this issue happened. The project Ive been
given to extend has openesb-2.3 with Sun GlassFish Enterprise Server v2.1.1
+ Netbeans. I have extended the existing web services with further
functionality and although it works when the service is called via netbeans
with a use case, the same use case does not lead to a result when called
externally, that is, it hangs on some Java classes, for instance when
applying the functionality of Jsoup. Initially, I looked into aligning both
the jre and the jdk since one was 1.6 and the other 1.7 but the problem
persists. I've been stuck for a while with this issue and wondered how to
continue investigating for solutions to it. Why is the project totally
functioning internally yet it hangs when called externally with the same use
case and parameters?
Thank you in advance for any guidance.



--
Sent from: http://openesb-community-forum.794670.n2.nabble.com/



More information about the User mailing list